About

About Program SDC

Настоящий документ описывает функциональные возможности программного комплекса «Software Defined Connectors» (сокращенно «SDC»).

Краткий обзор возможностей программы:
- "ProFile Manager". Работа с настроечными профилями программ 5MContest и ExpertSDR2.

- "COM Spider". Создание любых соединений СОМ портов. Перенос СОМ порта на удаленный компьютер. Формирование телеграфа на удаленном компьютере с использованием протокола ASC-команд (удобен для трансиверов, которые не обрабатывают CW по порту САТ). В протокол добавлены команды ускорения, замедления и немедленной остановки передачи. Передача CW манипуляции на удаленный компьютер с выдерживанием интервалов переключений. Подключение нескольких логов к одному трансиверу.

- “RIG Sync”. Синхронизация приемников и трансиверов любых типов. Используется своя система опроса, позволяющая реализовать быструю синхронизацию. Возможна синхронизация с клиентами OmniRig и SDR программами, поддерживающими протокол ExpertSync по TCP соединениям, или TCI интерфейс.

- "Telnet Server". Позволяет организовать свой telnet server для сбора спотов из множества источников и передачи их через один порт. Может автоматически запускать скиммеры из раздела SKM Server. Telnet Server "понимает", кто к нему подключается и может запускать соответствующие профили для программы 5MContest и других логов. Суммирует и передает споты на панораму программы ExpertSDR2. Интеграция с 5MContest, N1MM, LogHX и др.

- “SKM Server”. Организация и подключение скиммеров телеграфных, RTTY и PSK сигналов к трансиверам и приемникам, работающим под управлением программы ExpertSDR2.

- "DIGI Server". Цифровой модуль для подключения к внешним логам и автономной работы. Имеет встроенные модуляторы/демодуляторы для RTTY45,75, BPSK31-125. Для его работы используется только TCI. Для подключения логов каждый модуль имет встроенный Telnet Server.

- "MACROS Server". Панели кнопок для передачи макросов в CW, DIGI, SSB через TCI.

- "Remote Audio & COM port:". Создание удаленных подключений для передачи аудио потоков данных и COM-портов.

- “Mixer”. Создание всевозможных соединений и разделений аудио потоков.

- "Audio Scope". Окна для анализа спекра и временной развертки аудио сигналов.

- “PA”. Управление усилителями мощности.

- "SWR Meter:" Графики КСВ для анализа. Используется протокол TCI.

- "OTRSP:" Управление звуком трансивера через протокол OTRSP.

- "TCI Client:" Для подключения трансивера к SDC, работающего через интерфейс TCI. Он имеет встроенную функцию «FocusHelper» для работы с N1MM, 5MContest и другими журналами. Имеет раздел "RIG-Emulator" для подключения устройств и программ через интерфеййййс CAT-COM port.

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Создание «укороченных» профилей

ProFile Manager ››

Для сохранения текущих установок с целью их быстрого восстановления в будущем программа ExpertSDR2 использует систему профилей. В файл профиля входят все установки для всех систем программы. Это не всегда удобно, т.к., часто возникает необходимость сохранения и восстановления только части установок, например, только настройки виртуальных аудио кабелей. Рассмотрим такой вариант в качестве примера.

После того, как все установки внесены в программу ExpertSDR2, создаем профиль с названием, например, «vac_digi»:

Затем запускаем программу «SDC» и в первой вкладке кнопкой [File 1] открываем этот файл:

После открытия файла мы увидим «дерево» профиля, где ищем установки VAC и проставляем галки в каждой ветви, относящейся к VAC, или ставим галки на главных ветвях:

Если мы не хотим сохранять какие-то установки, например, установки задержки, то в соответствующих ветвях надо убрать галки. После этого давим кнопку [Create] – создается «дерево» будущего профиля, нажимаем кнопку [Save] и пишем имя будущего файла, или выбираем тот же:

Таким образом, мы получаем «укороченный» профиль, в котором будут прописаны только установки для аудио кабелей.

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation

Copyright © UT4LW-2021 All Rights Reserved.


Создание профиля из двух ранее сохраненных профилей

ProFile Manager ››

На основании двух имеющихся профилей можно создать третий с выбранными установками. Например, из нового профиля необходимо выбрать установки размера окна программы и добавить установки аудио кабелей, созданных в пункте 1.1.

Создаем новый профиль с названием, например, «size_vac», открываем его в программе «SDC» кнопкой [File 1], кнопкой [File 2] открыть другой профиль («vac_digi»):

Кнопкой [Create] создаем дерево нового профиля и сохраняем его. Таким образом, мы взяли из полного профиля только установки размеров окна программы, добавили к ним установки аудио кабелей и получили совмещенный профиль.

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Обновление профиля (As File2)

ProFile Manager ››

В работе часто будут создаваться ситуации, когда необходимо будет изменить уже созданный «укороченный» профиль. Чтобы не вспоминать, какие установки в нем сохранены, предусмотрена возможность быстрой расстановки отметок для тех установках, которые есть в профиле [File 2]. Для этого, создается новый профиль, он открывается в программе «SDC» кнопкой [File 1], кнопкой [File 2] открывается ранее созданный укороченный профиль и нажимается кнопка [As File 2]. В результате, в профиле [File 1] будут расставлены отметки для тех установок, которые есть в профиле [File 2]:

Затем нажимаем кнопку [Создать], затем сохраняем профиль кнопкой [Сохранить].

Created with the Personal Edition of HelpNDoc: Free EPub producer


Обновление профиля (Use as template)

ProFile Manager ››

Это вариант обновления укороченного профиля, когда его старый файл используется в режиме «как образец». Открываем новый профиль, открываем старый профиль, ставим галку «Use as a template», нажимаем кнопку [Create], затем сохранить. Этот способ отличается от предыдущего тем, что, если в исходном профиде по каким-то причинам не окажется установок, которые есть в «образце», то они будут добавлены из него при создании нового профиля.

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Работа с профилями программы 5MContest

ProFile Manager ››

Для переключения программы для работы в профилями программы 5MContest необходимо указать её в выпадающем меню «For Program:»

Дальнейшая работа с профилями программы 5MContest ничем не отличается от работы с профилями программы ExpertSDR2.

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


COM-Spider

Created with the Personal Edition of HelpNDoc: Create help files for the Qt Help Framework


Создание соединений СОМ-портов

COM-Spider ››

Программа «SDC» позволит создать любые виды соединений СОМ-портов, как физических, так и виртуальных. Например, стоит такая задача:

Имеется реальный СОМ-порт COM3, который подключен к усилителю ОМ-2500. Имеется виртуальный порт СОМ10 (из пары СОМ9-СОМ10), который подключен портом СОМ9 к системе САТ трансивера SunSDR2. Имеется порт СОМ12 (из пары СОМ11-СОМ12), который портом СОМ11 подключен в контестовому логу. Задача состоит в том, чтобы связать эти три системы в одну. Чтобы состояние настроек трансивера транслировались и в усилитель, и в лог.

При этом данные нужно передавать от трансивера в усилитель, и обратно, и из трансивера в лог, и обратно. Состояние линий DTR/RTS (управление PTT и CW) необходимо передавать только от лога в трансивер.

В программе «SDC» открываем вкладку “COM Spider”, кнопкой [+] открываем три порта: A, B, C . Ставим галки, что говорит о том, что эти порты будут использоваться. Указываем наименования портов соответственно COM11, COM9, COM3, устанавливаем (при необходимости) свойства портов (Baud rate, Data bits…). В разделе “Send Data to” для потра СОМ11 ставим галку напротив порта СОМ9. Это говорит о том, что данные от лога будут передаваться только в ExpertSDR2. В разделе “Send DTR/RTS to” порта СОМ11 отмечаем галкой порт СОМ9 - это говорит о том, что лог будет передавать управление PTT/CW только в программу ExpertSDR2.

В разделе “Send Data to” порта СОМ9 ставим галки для портов СОМ11 и СОМ3 – это говорит о том, что данные будут передаваться и в лог, и в усилитель.

В разделе “Send Data to” порта СОМ3 ставим галку для порта СОМ9 – данные из усилителя будут передаваться в ExpertSDR2.

Остается нажать кнопку [Start] для запуска всех этих соединений.

В практике может возникнуть множество вариантов соединений портов. Поэтому введена система профилей. Т.е. текущее состояние соединений Вы можете сохранить в профиль. Для этого вводим его название в поле возле кнопки [Add] и нажимаем кнопку [Add]. После этого название профиля появится в перечне:

Для сохранения изменений в уже существующем профиле есть кнопка [Upd], для удаление профиля – кнопка [X].

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Соединение СОМ-порт – Сеть – СОМ-порт

COM-Spider ››

Не исключены ситуации, когда необходимо создать соединение СОМ-портов, расположенных на разных компьютерах посредством компьютерной сети. Например, наш усилитель (ОМ-2500) оказался подключенным к другому компьютеру к СОМ-порту СОМ3. Для этого на удаленный компьютер необходимо установить программу «SDC» и использовать ярлык “SDC Server” – это сервер для создания удаленных соединений СОМ, аудио портов и скиммеров. В таком варианте соединение будет выглядеть так:

На нашем компьютере в программе «SDC» делаем такие изменения:

На удаленном компьютере заускаем программу “SDC” и во вкладке «Audio/COM Server ”, ставим галку «LAN-COM interface 1», указывам СОМ-порт, к которому будет подключен усилитель (в нашем случае СОМ3), номер сетевого порта (выбираем самостоятельно, например, 7101) и нажимаем кнопку [Start]. Сервер включен и ожидает подключения.

Внимание! При выборе типа порта с использованием TCP соединений будет появляться поле «Latency». Это значение, на которое будет задерживаться передача манипуляции линий RTS и DTR. На сервере будет создаваться временной буфер для того, чтобы выдержать время между переключениями состояний этих линий таким, каким оно было на стороне клиента. Таким образом CW манипуляция не будет зависеть от изменений скорости передачи данных по сети. Чем хуже сеть, тем больше значение «Latency» необходимо установить. Обычно 50-200 мс.

Таким образом, мы соединили два виртуальных порта своего компьютера с реальным СОМ-портом на удаленном компьютере через сеть.

Возможность создания «сетевых» соединений СОМ-портов может быть использована при работе с двух рабочих мест на одном трансивере SunSDR2 (PRO). САТ второго приемника можно передать через сеть на второй компьютер для подключения к установленному на нем логу.

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Порт «as Server»

COM-Spider ››

Если в настройке порта отметка «as Server» не поставлена, то порт будет рассылать сообщения всем портам, которые указаны в разделе «Send data to». Так, если в порт «В» поступил запрос от порта «А», то ответ будет разослан всем. Если установить отметку «as Server», то ответы порт будет отправлять тому порту, который отправил запрос. Такой порт («as Server») позволяет реализовать подключение нескольких логов к одному САТ порту трансивера.

Дополнительно устанавливается параметр «Timeout», который регулирует время ожидания ответа от трансивера. Подбирается экспериментально, цель – исключить переполнение буфера запросов и до конца получить ответ от медленных СОМ портов. В случае переполнения рядом с отметкой «as Server» появится надпись «OVF!». Допускается подключение множества аппаратных журналов и устройств, которые ведут свой опрос САТ портов трансиверов.

Пример подключения к одному САТ порту трансивера двух аппаратных журналов:

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Filter

COM-Spider ››

Для сложных ситуаций предусмотрен фильтр запросов/команд, поступающих по соединениям «COMSpider».

Выражения «Да». Строки, которые будут допускаться в порт. Например: FA|FB означает, что только команды, содержащие фразы «FA», или «FB» будут пропускаться в порт.

Выражения «Нет». Эти фразы должны начинаться на восклицательный знак. Например: !FA|!FB означает, что команды, содержащие фразы «FA» или «FB» НЕ будут пропускаться в порт.

Выражения можно писать в формате HEX, например, &FDFE – пропускать в порт команды, содержащие байты FDFE.

Created with the Personal Edition of HelpNDoc: Free Web Help generator


RIG Sync

В программу SDC внедрена система синхронизации трансиверов (приемников) по частотам VFO, видам модуляции, сплит, и другим параметрам. Работают два независимых канала синхронизации, каждый из которых может связан с соответствующим устройством, подключенным к OmniRig, или приемником, работающим под управленим программы ExpertSDR2.

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Синхронизация по протоколам САТ с использованием СОМ портов.

RIG Sync ››

Рассмотрим на примере синхронизации трансивера TS-590 и SDR приемника, работающим под управлением программы SDRuno, или любой другой программы, поддерживающей САТ, или TCI протокол.

Как видим, активирован только один канал синхронизации (Sync Channel 1). В нем активированы два «Rig Control» - один для TS-590, второй – для SDR приемника.

Device Name – имя устройства (информативно).

RIG Protocol – в выпадающем списке выбирается устройство.

Port – В выпадающем списке выбирается СОМ порт, к которому подключено устройство.

Poll Time – время между опросами порта.

Timeout – время ожидания ответа.

Poll cmd – производить опрос устройства.

Offset - смещение частоты. Например, если указать 1000, то к частоте данного устройства будет добавлено 1 кГц.

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Синхронизация по протоколам САТ с портами, открытыми в COM Spider

RIG Sync ››

Как быть, если СОМ порт основного трансивера (приемника) уже соединен с аппаратным журналом. Для этого можно предусмотрено два режима – режим «подслушивания» и режим с самостоятельным опросом порта трансивера.

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Режим «подслушивания»

RIG Sync ›› Синхронизация по протоколам САТ с портами, открытыми в COM Spider ››

В таком случае данные по частоте и статусам основного траснивера «подслушиваются» из обмена трансивер – аппаратный журнал. Для этого СОМ порт аппаратного журнала и СОМ порт трансивера соединяются во вкладке СOM Spider:

Во вкладке RigSync настройки такие:

В выпадающем списке «Port» необходимо указать порт из вкладки «COM Spider». Если в меню устройства не оказалось, то нажмите кнопку обновления списка и найдите его:

Синхронизация при такой установке будет происходить только при подключенном аппаратном журнале, т.к. его программа будет опрашивать СОМ порт основного трансивера, программа «RigSync» будет «подслушивать» этот обмен и передавать его второму устройству (SDRuno). Кроме того, скорость синхронизации устройств будет зависеть от скорости опроса апаратного журнала.

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Режим с опросом порта основного трансивера

RIG Sync ›› Синхронизация по протоколам САТ с портами, открытыми в COM Spider ››

Для такого режима подключение аппаратного журнала не обязательно, т.к. программа «RigSync» будет сама опрашивать СОМ порт основного трансивера. Для этого, его порт переводится в режим «as Server»:

а в «RigSync» включаем опрос этого порта:

В таком режиме порт порта основного трансивера будет поочередно отвечать на запросы от аппаратного журнала и от программы синхронизации. Сама синхронизация будет работать быстро (скорость устанавливается в Poll Time) и не будет разрываться при отключении аппаратного журнала.

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Синхронизация трансивера с ExpertSDR2 и логом N1MM

RIG Sync ›› Синхронизация по протоколам САТ с портами, открытыми в COM Spider ››

В окне COM Spider вводим два порта - один соединен с N1MM, второй - с трансивером FT-1000.

Порт трансивера объявляется, как сервер. Он будет поочередно отвечать на запросы программы N1MM и программы синхронизации.

В окне RigSync вводим два устройства синхронизации:

ESDR - Указываем имя TCI-клиента и номер приемника.

FT-1000 - указываем порт из вкладки COM Spider.

Возможно придется подобрать время ожидания для трансивера в окнах COM Spider и RIG Sync.

В настроках программы SDC указываем автоматический запуск программ COM Spider и RIG Sync

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


Использование клиента OmniRig

RIG Sync ››

Если аппаратный журнал работает через OmniRig, то можно значительно упростить синхронизацию. Для этого не нужно использовать «COM Spider» достаточно во вкладке «RigSync» указать синхронизируемое устройство и поставить галку «OmniRig»:

В таком случае синхронизация будет работать со скоростью опроса порта основного трансивера программой «OmniRig».

Created with the Personal Edition of HelpNDoc: Easily create Qt Help files


Синхронизация устройств ExpertSDR2 с другими трансиверами/приемниками

RIG Sync ›› ExpertSDR2 Server ››

Для синхронизации с трансивером, который работает с логом через OmniRig достаточно добавить отметку «OmniRig»:

Аналогично можно устраивать синхронизации с трансиверами, работающими через СОМ порты, в рассмотренных выше режимах (с подслушиванием, с прямым опросом, и т.д…..).

Например, синхронизация приемника Colibri с трансивером TS-590 с прямым опросом порта и подключением к аппаратному журналу через СОМ порт:

Синхронизация двух приемников одного приемника Colibri с двумя TS-590 для режима SO2R:

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Сложные варианты синхронизации устройств

RIG Sync ››

Задача: необходима синхронизация трансивера TS-590 с SDR приемником для работы с программой 5MContest в режиме SO2V. При этом во время передачи из VFOA, должна работать синхронизация лога с SDR приемником для перехода по спотам на бендмапе для VFOB. Т.е. трансивер TS-590 работает на CQ, а в это время мы прослушиваем станции по VFOB. Для этого и TS-590 и SDR подключаются к портам COM Spider в режиме «as Server»:

Для того, чтобы опрос, идущий от лога не сбивал синхронизацию, для порта приемника устанавливаем фильтр:

!FR|!FT|!FA;|!FB;|!IF;

Это означает, что приемник не будет отвечать на запросы и команды лога, кроме команды FB000XXXX;, которая будет устанавливать частоту приемника по VFOB лога.

Во вкладке «RigSync» настройки выглядят так:

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Добавление своих ini файлов для устройств

RIG Sync ››

INI файлы формата OmniRig записываются в папку "Rigs" при установке программы.

Если Вы хотите добавить свои файлы, то можете добавить их папку пользователя "C:\User\...user_name...\LwSoft\Rigs\". Добавленные таким образом файлы будут показаны в списке устройств с отместкой "User: ":

Created with the Personal Edition of HelpNDoc: Write eBooks for the Kindle


RIG-Emulator

RIG Sync ››

В версии SDC 12.20 в разделе RigSync появился новый тип порта - "RIG-Emulator". Этот порт предназначен для подключения к нему программ. Например, так выглядит синхронизация трансивера К3, панорамы NaP3, программы JTDX, и программы лога LogHX.

Это позволит полностью отказаться от использования OmniRig и различных сплиттеров COM портов.

В чем преимущества такого подхода к синхронизации (через новый SDC - RIGSync) по сравнению со всякими СОМ-сплиттерами, или COM Spider:
- мы не ограничены в количестве подключаемых программ. Все они подключены к своим портам RIGSync и не мешают друг другу.
- мы не ограничены в количестве устройств, они тоже подключены каждый к своему порту и не мешают друг другу.
- мы можем использовать устройства, которые поддерживают разные САТ потоколы. Например, вместо К3 можно подключить Icom и указать его протокол. Для СОМ-сплиттеров это принципиально невозможная ситуация. Тот же NaP3 не поддерживает синхронизацию с Айкомами, зато это легко может сделать SDC-RIGSync, т.к. ему все равно, какой трансивер к нему подключен - надо просто выбрать из списка синхронизируемое устройство.
- синхронизируемые параметры, например, частота VFO, защищены от "болтанки" (при изменении частоты, она может прыгать вверх/вниз), что часто наблюдается при использовании СОМ сплиттеров.

Created with the Personal Edition of HelpNDoc: Free EPub producer


Примеры синхронизации

RIG Sync ››

Created with the Personal Edition of HelpNDoc: Easy EPub and documentation editor


Трансивер+ColibriNano

RIG Sync ›› Примеры синхронизации ››

1. Подключаем SDC к Colibri:

2. В RIG Sync подключаем RIG Control к Colibri и к трансиверу, например, TS-590:

3. Проверяем работу синхронизации.

4. Добавляем к синхронизации программу контест лога. Для этого нам понадобится пара виртуальх COM портов, например, COM5-COM6. В RIG Sync указываем COM5, в программе лога - COM6. N1MM подключается к RIG-Sync, как к трансиверу TS-480.

Вы можете добавить сюда любое количество программ и устройств. Например:

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


TCI

Компанией Expert Electronics разработан и внедрен в ПО ExpertSDR2 новый протокол для управления и получения данных от трансивера. Он позволяет реализовать передачу и прием данных по одному соединению, что значительно упростит настройку внешнего ПО и увеличит надежность работы комплекса в целом.

Комплекса Подключение по протоколу TCI описывается во вкладке «TCI».

Для добавления/удаления клиента TCI воспользуйтесь кнопками +/-. Если Вы планируете работу с двумя и более трансиверами (приемниками), создавайте соответствующее количество клиентов TCI.

Указывается имя подключения (оно в дальнейшем будет использоваться в других разделах SDC), адрес и порт.

! Кнопку «Connect» следует использовать только для проверки соединения с трансивером. Оставлять её в нажатом состоянии нет необходимости.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Режим CallBack

TCI ››

Для того, чтобы программа SDC подключалась к серверу TCI трансивера необходимо, чтобы первая программа как-то узнала, что вторая программа готова к соединению.

Для этого есть два пути:

- Программа SDC постоянно проверяет наличие сервера TCI в программе трансивера.

- Программа трансивера информирует программу SDC о том, что она включена и программа SDC начинает подключение к серверу TCI трансивера.

Первый вариант работает, но постоянное сканирование порта может быть интерпретировано системой защиты, как вредоносное с последующим блокированием.

Поэтому для более надежного соединения с программой трансивера введен режим "обратного звонка".

В SDC разработано две системы обратного вызова:

Для ExpertSDR2 - Callback TCP-Connect mode.

Для ExpertSDR3 - Callback UDP-Connect mode.

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Callback TCP-Connect mode

TCI ›› Режим CallBack ››

Callback TCP-Connect mode:

Как это работает:

При подключении к порту, указанному в "Port", клиент TCI из программы SDC начинает автоматическое подключение к серверу TCI программы трансивера.

Для этого в программе ExpertSDR2 необходимо указать фиктивного клиента, который будет подключаться к порту "Callback", например:

При запуске программы ExpertSDR2 будет создано её соединение с портом "Callback" программы SDC. Это будет сигналом того, что программа трансивера включена и можно начинать соединение с TCI сервером.

Протокол работы программы SDC-TCI-Callback:

После запуска программммммы SDC, она произведет попытку подключения к серверу TCI. Если она не будет успешной, то программа SDC перейдет в режим CallBack и будет ожидать подключения к порту CallBack.

Запускается программа трансивера. Она автоматически подключается к порту CallBack программы SDC. Если подключение удалось, то в программе SDC запускается процедура подключения к серверу TCI.

После выключения программы трансивера, SDC повторит попытку подключения к серверу TCI. Если она не будут успешной, то SDC опять перейдет в режим CallBack.

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Callback UDP-Connect mode

TCI ›› Режим CallBack ››

Для новой программы ExpertSDR3 лучше подходит система "Callback UDP-Connect mode"

После неудачных попыток подключиться к TCI серверу трансивера SDC-TCI Client переходит в режим ожидания оповещения по порту UDP, указанному в настройке. Для этого в программе ExpertSDR3 необходимо включить широковещательное оповещение:

Created with the Personal Edition of HelpNDoc: Full-featured EPub generator


Эмулятор САТ порта

TCI ››

CAT Port Emulator - это система, которая позволяет создавать САТ порты для подключения к ним программ логов, или устройств. САТ порты, созданные ей полностью эмулируют работу порта CAT програмы трансивера. Можно создавать несколько портов для одновременного подключения программ, или устройств.

Чтобы система CAT Port Emulator была доступна, поставьте галку "CAT Port Emulator". Нажмите кнопкку "+", чтобы добавить порт.

После добавления порта, укажите его тип: CAT, PTT, Foot Switch. Выберите приемник, к которому будет подключен порт, укажмите имя COM порта.

Типы портов:

CAT - создается COM порт, работающий по протоколу трансивера TS-480. В этом же порте можно указать пин PTT (DTR/RTS).

PTT - для подключения внешних источников PTT от других программ, или устройств.

Foot - для подключения педали.

В режиме CAT, PTT и виде модуляции SSB, к передатчику будет подключаться вход VAC (виртуальный аудио кабель). В режмие Foot - микрофон.

Для ввода параметров COM порта, выбора пина для PTT и CW, нажмите шестеренку возле названия порта:

Created with the Personal Edition of HelpNDoc: Easily create EBooks


TC команда.

TCI ›› Эмулятор САТ порта ››

Для выполнения команды в формате TCI можно использовать команду TC:command;

где command - текст, который будет отправлен в сервер TCI трансивера. Если формат команды TCI содержит номер приемника, то указывайте вместо него аргумент "%1", который будет означать номер приемника, к которому подключена программа CAT.

Например, Вы можете отправлять CW макросы из программы N1MM:

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


VAC эмулятор

TCI ››

Для подключения цифровых программ, которые не имеют интерфейса TCI, можно использовать VAC - Emulator.

Created with the Personal Edition of HelpNDoc: Benefits of a Help Authoring Tool


Focus Helper

TCI ››

Система "Focus Helper" находится в разделе TCI и работает непосредственно с клиентом TCI. Чтобы система была доступна, поставьте галку "Focus Helper"/

Она предназначена для автоматического возврата фокуса ввода в окно ввода QSO программы лога.

Synchronize work with TCP Server - синхронизировать запуск этой системы с подключением к Телнет Серверу (см. вкладку Telnet Server).

Also SDC Windows - возвращать фокус в окно лога, если фокус передан в какое-либо окго SDC.

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


N1MM

TCI ›› Focus Helper ››

Для работы с N1MM.

Указывается широковещательный порт в программе N1MM, который производит рассылку данных программы. Его номер указан тут:

Для контроля за правильностью соединения с N1MM поставьте галку "Log". От программы N1MM должна периодически поступать такая информация:

Delay (ms) - указывается задержка передачи фокуса в окно лога N1MM.

Если если информация от лога N1MM получена, то загорается сообщение "Ok":

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Window Name

TCI ›› Focus Helper ››

Для работы системы "Focus Helper" с другими программами выберите тип работы: Window Name.

Window Title for VFOA, VFOB - указывается заголовок окна ввода QSO для VFOA, VFOB (если такое есть). Можно вводить начало его названия, например, "Radio 1".

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


CW Key Helper

TCI ››

CW Key Helper решает две проблемы работы с телеграфным ключом:

1. Создание задержки сигнала телеграфа после выдачи сигнала PTT. Это особенно актуально для работы трансивера с усилителем.

2. Возможность работы ключом в режиме BreakIn для 2-го приемника.

Сигналы манипуляции ключом принимаются через COM порт, обрабатываются в программе SDC-CW Key Helper и подаются в программу ExpertSDR2. Схема работы:

Недостаток такой схемы заключается в том, что на корпусе ключа будет присутствовать некоторый потенциал. Поэтому желательно ввести в схему оптронную развязку.

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


SKM Server

В программе SDC имеется встроенный скиммер-сервер для подключения и работы с трансиверами и приемниками, работающими под управлением ExpertSDR2. Подключение и управление скиммерами происходит в автоматическом режиме, синхронно с работой приемников.

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Главное окно

SKM Server ››

Панель управления:

[Start SKM Server] – для ручного запуска всех скиммеров. При работе с Telnet Server нажимать эту кнопку не нужно, т.к. это будет происходить автоматически.

[+] [-] –добвить, удалить скиммер.

Profile: выбор, удаление, перезапись, создание профиля.

Only Test - споты будут выдаваться только для тех станций, которые передают слова TEST, WSEM.

Only Test Abbr - споты будут выдаваться только для тех станций, которые передают специальную аббревиатуру теста. Вы можете указать неколько вариантов через запятую, точку с запятой, или пробел. Например, указав «MM» - Вы будете получать споты только тех станций, которые в вызове добавляют буквы MM: CQ MM..., TEST MM...

Add Sign Test - дополнительные слова, обозначающие, что станция работает в тесте. Например, не все станции, работающие в тесте передают слово TEST, а передают только аббревиатуру теста.

Например, станция передает: UT4LW UT4LW LZ. В данном случае скиммер должен знать, что LZ - это то же самое, что слово TEST. Для этого введите LZ в поле Add Sign Test.

-----

-Кнопка очистки истории декодированных позывных.

- Вызов окна глобальных установок SKM Server.

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Глобальные установки.

SKM Server ››

Окно глобальных настроек SKM Server разбито на четыре вкладки.

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Master.dta/Verify

SKM Server ›› Глобальные установки. ››

Master.DTA File Location: указывается место расположения и имя файла с позывными.

Internet Download Page: указывается страница в интернете, где доступен файл для скачивания.

Add File: указывается дополнительный файл с позывными. Это необходимо для быстрого декодирования позывных, которые не вошли в Master.dta. Вы можете создать такой файл, и редактировать его.

Black List: указывается файл с перечнем позывных, которые не будут декодированы скиммером. Вы можете создать такой файл, и редактировать его.

Special Calls Format: Указывается формат специальных позывных, которые имеют разовый характер и не входят в файлы Master.dta. Например, в соревновании для очных участников будут выданы временные позывные. Их формат необходимо ввести и указать количество декодирований перед выдечей спота. Например, на очных соревнованиях будут выданы временные позывные в формате R31A/P ... R37Z/P. Этих позывных нет в справочнике Master.DTA, но их проверку можно ускорить, если указать формат этих позывных. В данном случает формат выглядит так:

R3[1-7]?/P, где

[1-7] - возможна цифра от 1 до 7.

? - любой знак.

Правильнее будет указать такой формат:

R3[1-7][A-Z]/P

Если формат введен неправильно, то появится сообщение об ошибке:

Special Black List Format: Указывается формат позывных, которые не должны декодироваться скиммером. Например, если в CQ WW необходимо заперить выдачу спотов для украинских станций, можно ввести формат: U[R,S,T,Y,X,W,Z][0-9]*. Если формат введен неправильно, то появится сообщение об ошибке.

Filter Calls Format: Вводится регулярное выражение для отбра позывных, удовлетворяющих условию фильтра. Например, выражение:

(R[\w,/]{2,})|(U[A-I][\w,/]{2,})

будет отбирать только российские позывные.

Check Callsign: для проверки наличия позывного в файлах Master.dta, Add File и Special Calls Format. Введите позывной в окно и нажмите "Check Call". Появится окно:

Раздел Verify Call. Тут настраивается проверка правильности определения позывного:

Strong signal and Call in DTA – Для мощных сигналов и позывных, которые внесены в справочник Master.DTA. Если установлено 1, то достаточно однократного декодирования такого позывного для отправки спота.

Weak signal and Call in DTA – Для слабых сигналов и позывных, которые внесены в справочник Master.DTA.

Call not in DTA – для станций, которые не внесены в справочник Master.DTA.

Например, если в последнем пункте установлено 3, то только после троекратного декодирования позывного не внесенного в справочник Master.DTA будет сгенерирован спот.

Without CQ (0-newer) – указывается количество повторных декодирований для отправки спота для станций, которые не указывают в вызове аббревиатуру CQ, TEST, WSEM.

Minimum signal/noise level for spotting (dB) - Указывается нижняя граница громкости станции для выдачи спота. Например, если Вы не хотите иметь споты для станций слабее 12 дБ, укажите 12. Для отключения этой возможности введите -10.

Resending spot after (secs) - повторить выдачу спота по после N секунд.

Resending spot after pause: - повторить выдачу спота, если в течении N секунд станция молчала.

Created with the Personal Edition of HelpNDoc: Create cross-platform Qt Help files


Файлы "add_dta.txt" и "blacklist.txt"

SKM Server ›› Глобальные установки. ›› Master.dta/Verify ››

Если позывной отсутствует в файле "Master.DTA", Вы его можете внести в файл "add_dta.txt".

Вы можете создать такой файл текстовым редактором и указать его с помощью кнопки "Set File". Можно нажать кнопку записи в файл. Если имя файла не указано, то файл "add_dta.txt" будет автоматически создан в папке пользователя:

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


Band Plan

SKM Server ›› Глобальные установки. ››

Band Plan – частотный план по диапазонам. В таблице указываются промежутки частот, в которых будет производиться декодирование CW/RTTY станций и генерация спотов.

Допускается создание набора частотных планов с сохранением их в профили.

Вс каждой строке можно указать вид модуляции. ALL - все виды, CW, RTTY, PSK.

Можно подготовить Band Plan для всех видов модуляции, например:

Для указания участков, в которых не нужно производить поиск станций, разработан вид модуляции - BSF (Band Stop Filter). Например, в 7-й строке указан участок 3573 - 3577, где постоянно работают станции с другими видами модуляции. Для активации этих фильтров нажмите кнопку [BSF].

На шкале скиммера эти участки выводятся другим цветом, например:

- кнопки добавить строку, удалить строку, активировать BSF, создать Band Plan "по умолчанию", применить введенные изменения.

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Functions

SKM Server ›› Глобальные установки. ››

Send RST 599 to Panorama.

PileUp Width, kHz - ширина пайлапа, в которой идет поиск рапортов 599

Marker New RST - отображать маркер последнего рапорта.

Marker Old RTS - отображать маркер предыдущего рапорта.

Выбор типа маркера:

- ASCII - ASCII код символа, который будет отображен в качестве маркера.

- Если значение ASCII кода равно нулю, то можно указать текстовое выражение маркера.

Работа с функцией 599 см. тут.

Auto CW Macros Speed (TCI only) : Включает автоматическое управление скоростью CW передачи при настройке трансивера на данную станцию. Работает только с трансиверами, работающими через протокол TCI.

Default - скорость по умоланию.

Add technical information into Spot - добавить техническую информацию в комментарий к споту. F - позывной найден в справочнике, количество декодирований, и т.д.

Check the primacy of the Skimmer Spot - проверить первичность скиммерного спота относительно других споттеров. Если скиммер определил позывной ранее всех остальных споттеров, то комментарий к споту будет начинаться на два знака "!!".

Start Skimmers Only in CW Mode: включать скиммер только в случае, если выбран вид модуляции "CW".

Color Callsing in BandMap: Включить функцию раскрашивания позывных на BandMap. Она будет работать с логами, которые передают программе SDC сведения о типе позывного: 5MContest, LogHX, N1MM. Если подключился такой лог, то на BandMap появятся значки:

CW Decoder Setup. Установки детектора телеграфного сигнала.

Decode Russian letters: - включить декодирование русских букв.

Remove noise Letters (E,I) - удалять буквы, декодированные из шума.

Active decoder Filter Width - ширина фильтра декодера, который выводит текст в окно декодера.

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Misc

SKM Server ›› Глобальные установки. ››

TCP Broadcast Data - сервер для рассылки текстов активных декодеров скиммеров.

Created with the Personal Edition of HelpNDoc: Easily create iPhone documentation


Окно Скиммера

SKM Server ››

Окно «Waterfall».

Start – для ручного запуска скиммера. При работе с Telnet Server запуск скиммера будет происходить автоматически.

Status – окно состояния скиммера.

1 - количество декодированных позывных.

42 – количество активных декодеров в данный момент времени.

192kHz/Auto - Ширина полосы IQ канала - 192 кГц. Включено автоматическое определение.

TCI/Receiver 1 - источник IQ канала.

- Кнопка вызова окна настроек скиммера.

Справа от водопада размещается шкала частот с маркером те кущей настройки. Под водопадом находится окно с декодированным текстом на частоте настройки.

Вызов настроек водопада производится нажатие правой кнопки мышки на водопаде:

Fore Color, Back color - цвета водопада.

Contrast - контрастность водопада.

Waterfall Speed - скорость рисования водопада.

Vertical size - размер одного шага исти по вертикали.

Horizontal size - размер одного шага кисти по горизонтали.

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Выбор вида модуляции

SKM Server ››

SDC Skimmer декодирует и спотит станции с видами модуляции CW,RTTY,PSK

Если в установках скиммера не установлена галка "Start Skimmer Only Mode of Transceiver"

то Вы можете управлять видом модуляции прямо из окна декодера:

Так же Вы можете управялть видом модуляции из окна "ActiSpot":

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Установки скиммера.

SKM Server ››

In External Window - при запуске скиммера, его окно будет отображаться отдельно от основного окна SDC – для любителей наблюдать на движением CW-сигналов.

Control Type – выбор способа управления и передачи IQ потока.

TCI Only – управление и передача IQ потока будет производиться через интерфейс TCI.

Audio + TCI – управление будет производиться через интерфейс TCI, а передача IQ потока – через аудио устройство/VAC кабель.

Первый способ более устойчив, не требует никаких аудио-кабелей и их настроек.

Второй способ уменьшит нагрузку на ЦП, но будет зависеть от VAC кабелей, и настройки всей цепочки передачи IQ потока.

TCI Client – указывается TCI клиент, который описан во вкладке TCI программы SDC.

Receiver – указывается номер приемника, к которому подключается данный скиммер.

Если выбран вид управления Audio+TCI, то указывается вид звукового драйвера и звуковое устройство, через которое будет доставляться IQ поток.

Start Skimmer Only Mode of Transceiver: Если установлена эта галка, то скиммер будет включаться в работу только при соответствии видом модуляции в скиммере и в трансивере. Например, Skimmer типа CW будет работать только, если в трансивере выбран вид моделяции "CW"

Signal/Noise stations detect: Отношение сигнал/шум при котором будет включаться декодер. Delay: - задержка запуска декодера. Это уменьшит влияние помех, но может исказить первую будку передачи.

Offset for spor frequency. Для корректировки частоты спота выберите вид модуляции и введите значение:

Spotter Name – указывается имя споттера, которое будет использовано при генерации спотов.

Creeping Lines – отображать бегущие строки декодеров в окне скиммера. См. подробнее.

TCP Server – каждому скиммеру можно объявить свой сервер, к которому будут подключаться сторонние программы для приема спотов. Указывается порт.

External Text Decoder Window

Установки для окна, в которое выводится декодированный текст.

Enable Click Function: Если эта функция разрешена, то при клике по позывному в окне декодирования в контест-лог будет передана строка, содержащая информацию о клике, например: > To ALL de SKIMMER <1353Z> : Clicked on "IZ2QDC" at 14013.32

Separate windows for VFOA and VFOB: Будет объявлено два окна декодирования: отдельное для каждого VFO:

Decode only VFOA: Если объявлено одно окно декодера, то в него будет выводиться только текст из VFOA. Если эта галка не установлена, то при переключении активного VFOA/VFOB в окно будет выводится текст соответствующего VFO.

IQ - Band Plan control: Выводит на экран окно, которое отображает соответствие частотного плана и ширины обрабатываемого скиммером IQ потока:

Sample Rate: Установка ширины IQ канала.

Auto - доступно, если тип источника установлен "TCI Only". Если установлено "Auto", то ширина полосы будет устанавливаться исходя из полосы панорамы приемника.

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Spectrum via UDP

SKM Server ›› Установки скиммера. ››

В SDC-Skimmer предусмотрена возможность вывода потока данных в формате, предложенным N1MM, через UDP соединение.

Spectrum via UDP - включает рассылку UDP пакетов.

Host - адрес получателя.

Port - номер порта UDP соединения.

Speed - периодичность выдачи UDP пакета. Чем выше значение - тем выше скорость.

Name - имя для заголовка окна панорамы в программе, которая принимает UDP данные.

Pile-Up Mode - для экспедиций. Передаваться будет только участок спектра, начиная с частоты VFOA - 1 kHz до границы, указанной в поле "kHz Up"

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


Окно декодера

SKM Server ››

По умолчанию окна декодеров располагаются в окне скиммера под водопадом. Вы можете открепить их от окна скиммера и разместить их в любом удобном месте на экране. Для этого нажать мышку на букву VFO (A:, B:) и переместить окно в другое место:

Чтобы вернуть окно декодера в окно скиммера, возьмите его за букву VFO и переместите его в окно скиммера.

В окне декодера будет выводиться декодированный текст. Позывные будут выделены цветом. Возле буквы декодера будет показан последний декодированный позывной (S51DX). Для вызова настроек окна декодирования нажмите правую кнопку мышки:

В окне настроек Вы можете установить основные цвета, прозрачность, выбрать шрифт, и настроить отображение дополнительных элементов окна декодера:

Underline Call - подчеркивать позывной.

Mode Control - отображается вид модуляции. Если в настройках скиммера не установдлена галка "Start Skimmer Only of Mode Transceiver", то прямо из окна декодера Вы можете изменять вид модуляции скиммера (CW,RTYY,BPSK):

Speed CW - будет отображаться скорость работы станции при передаче позывного.

Age of Spot - Включить часы, показывающие время жизни спота.

Current Level - Отображать текущая громкость станции, работающей на данной частоте

CQ Call Level - Отображать громкость станции во время передачи позывного.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Клик функции

SKM Server ›› Окно декодера ››

Если в настроке скиммера разрешены клик-функции и Ваш контест-лог поддерживает обмен со скимером, то будут поддерживаться такие скиммер-команды:

1. Клик по позывному будет транслировать в лог команду: To ALL de SKIMMER <1353Z> : Clicked on "S51DX" at 14013.32

2. Выделение текста в окне декодера будет копировать этот текст в текстовый буфер обмена. Затем клавишами Ctrl+V Вы можете вставить этот текст в любую другую программу.

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Окно IQ/Band Plan

SKM Server ››

Это окно отображает соответствие между частотным планом диапазона и шириной IQ потока, который обрабатывается скиммером.

1 - Номер скиммера.

2 - Термометр, отображающий количество работающих декодеров.

3 - Обрабатываемый скиммером IQ поток.

4 - Частотный план диапазона.

Это окно позволяет Вам следить за тем, чтобы обрабатывался весь CW-диапазон. Если частотный план выйдет за пределы IQ потока, то красная скоба начнет мигать.

Частотный план устанавливается в глобальных настройках SKM-Server.

Ширина IQ потока зависит от нескольких установок:

1. От значения Sample Rate в настройках трансивера:

2. От значения Sample Rate в глобальных настройках Скиммера:

3. От положения центральной частоты IQ потока относительно частотного плана. В случае, когда центр будет сильно смещен, Вы увидите такую картину:

Это говорит о том, что полоса IQ потока смещена ниже по частоте относительно частотного плана. В программе трансивера переместите центральную частоту выше, это можно сделать правой кнопкой мышки.

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Функция 599

SKM Server ››

Функция 599 разработана для помощи в работе с DX-Up. Так же она может использоваться, как помощник для самого DX.

Включается она нажатием на кнопку "599" в окне ActiSpot, либо в окне глобальных установок скиммера.

Для запуска функции 599 необходимо включить режим "Split". Если функция активирована, свтодиод в кнопке "599" в окне "ActiSpot" начнет мигать.

Если Вы хотите, чтобы режим 599 включался без Split, уберите отметку:

В окне скиммера на шкале частот появится красная скоба, которая показывает границы работы функции "599". Синий маркер отображает частоту VFOA, красный - VFOB.

В пределах этих границ будут отображаться все декодированные позывные. Но споты для них выдаваться не будут. Для того, чтобы включить выдачу спотов для таких станций необходимо включить галку "Spotting only Pile-Up" в окне глобальных настроек. В таком режиме споты для станций за пределами границ Pile-Up выдаваться не будут.

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Окно информации о позывном.

SKM Server ››

Клик правой кнопкой мышки по позівному в окнах скиммера, Telnet Server - BandMap, в окне декодера скиммера вызовет окно информации о позывном:

In DTA File: Not Found - сообщение о том, что этого позывного в списке Master.DTA не найдено.

Кнопки "Add Callsign into Add DTA File" и "Add Callsign into BlackList File" - для добавления/удаления позывного из соответствующих файлов. Например, если позывной будет присутствовать в списке BlackList, то Вам будет предложено удалить его из этого файла:

Позывной, который присутствует в файле BlackList, будет отображаться зачеркнутым шрифтом. В окне скиммера, в окне декодера он показываться будет, но спот для него выдаваться не будет.

Если файлы "Add File", или "Black List" в глобальных настроках скиммера не указаны, то они будут созданы автоматически с именами "add_dta.txt", или "blacklist.txt".

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Управление скиммером через Telnet

SKM Server ››

После регистрации программы SDC Вы получаете возможность управлять скиммерами через встроенный в каждый скиммер TCP Server:

По специальному протоколу, разработанному VE3NEA , от приемника в скиммер передаются команды, указывающие центральную частоту IQ потока и настройки VFOA.

Через TCP Server работают программы ExpertSDR2, SmartSDR, Afedri.

Видео R5AU о подключении к SmartSDR (Flex-6700).

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


Источник VFO

SKM Server ›› Управление скиммером через Telnet ››

SDC скиммер может получать данные о частотах VFO двумя путями:

1. Telnet Server - данные о частоте VFOA берутся из того же сервера, через который идет управление скиммером.

2. RigSync Channel - частота настройки приемника берется из раздела синхронизации.

Способ RigSync Channel интересен тем, что Вы можете использовать два окне декодеров - для VFOA, и для VFOB.

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Управление скиммером через RIG Sync

SKM Server ››

После регистрации программы SDC Вы получаете возможность управлять скиммерами через подсистему SDC - RIG Sync. Данные о текущей частоте VFOA/VFOB будут браться из вкладки RIG Sync:

Во вкладе RIG Sync Вы должны настроить синхронизацию любым способом. После этого В скиммере Вы указываете канал синхронизации, VFO, и, если нужно, частоту смещения.

Таким способом можно подключить скиммер к любой программе приемника, имеющией выход IQ канала и систему CAT.

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Ручное управление скиммером

SKM Server ››

После регистрации программы SDC Вы получаете возможность управлять скиммерами с помощью ручного ввода центральной частоты. Данные о текущей частоте VFOA/VFOB для декодеров будут браться из вкладки RIG Sync:

Центральную частоту IQ потока Вы должны вводить в поле "LO". Введенное значение будет принято только после нажатия клавиши Enter, или, когда курсор покинет поле "LO".

Если необходимо управлять декодерами, то во вкладе RIG Sync Вы должны настроить синхронизацию любым способом. После этого В скиммере Вы указываете канал синхронизации.

Таким способом можно подключить скиммер к любой программе приемника, имеющией выход IQ канала и систему CAT.

Created with the Personal Edition of HelpNDoc: Free help authoring environment


Бегущая строка

SKM Server ››

Бегущие строки декодеров отображаются справа от панели позывных. Для того, чтобы открыть раздел бегущих строк, воспользуйтесь специальными сплиттерами:

Для включения режима отображения бегущих строк откройте окно настроек скиммера:

Выберите один из режимов:

Off - режим отображения бегущих строк выключен.

Verifued Call Only - будут отображаться строки только для проверенных позывных.

All Station - будут отображаться строки для всех декодеров.

Не забывайте, что изменить масштаб по вертикали Вы можете удерживая и перемещая правую кнопку мышки по шкале частот:

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


599 в бегущей строке

SKM Server ›› Бегущая строка ››

Если включена функция 599 , то строка, в которой будет найдано слово "599" будет отмечена звездочкой:

Created with the Personal Edition of HelpNDoc: Free EPub producer


DIGI Server

В версии 14.01 в программу SDC введен DIGI Server. Это набор модемов для приема и передачи сигналов в модуляции RTTY, BPSK.

Модемы работают только через интерфейс TCI и не требуют аудиосоединений с трансивером.

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Настройка модема

DIGI Server ››

Чтобы добавить Модем, нажмите кнопку "+". Чтобы его настроить, нажмите кнопку с шестеренкой.

Настройка Модема:

In External Window - При запуске Модема отображать его в отдельном окне.

Stays On Top - Показывать окно на переднем плане.

Show AFC Panel - где будет отображаться панель управления AFC - в окне SDC, или во внешнем окне.

Show TX Panel - где будет отображаться панель управления TX - в окне SDC, или во внешнем окне.

TCI Client - Клиент TCI, к которому будет подключен Модем.

Receiver Channel - Приеник и VFO, к которому будет подключен Модем.

Default Offset - Смещение полосы приема. Должно соответствовать установке трансивера. Например:

TX Delay - задержка передачи сигнала после включения PTT.

TX Level, dB - корректировка уровня сигнала передачи в dB.

Spectr scale - вертикальная шкала спектра. Линейная, или логарифмическая.

PSK AFC Method - Метод работы AFC.

FIR Method - точная фазовая настройка в узком диапазоне.

FIR + FFT Method - точная фазовая настройка с захватом в более широкой полосе.

FFT Method - поиск станции в широкой полосе частот.

Sync Width Waterfall with RX filter band - автоматическая синхронизация ширины водопада с шириной полосы в трансивере.

Use TCP Server - открывать TCP Server для подключения внешних программ - логов. Если выбран такой способ, то запуск Модема будет происходить только после подлючения к его TCP серверу.

Управление размерами текстового окна и спектра производится перемещением разделителей между ними:

Created with the Personal Edition of HelpNDoc: Create help files for the Qt Help Framework


Настройка формирователя сигнала RTTY

DIGI Server ›› Настройка модема ››

Эти установки помогут Вам настроить сигнал передатчика RTTY.

Sharp Phase - простой фазовый формирователь RTTY сигнала. Имеет высокую стабильность уровня сигналов. Недостаток - высокий уровень помех в ближней зоне.

Soft Phase - Формирователь с мягким изменение фазы сигналов.

Ramp - количество семплов в течении которых происходит изменение фазы/амплитуды.

Amplitude - амплитудный метод формирования RTTY сигнала.

Для уменьшения уровня помех, можно включить дополнительный фильтр:

Настройка узкого фильтра с большим порядком значительно уменьшит уровень помех, но уменьшится уровень полезной выходной мощности.

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Водопад

DIGI Server ››

В окне водопада имеются такие органы управления:

1 - контрастность.

2 - порог чувствительности демодулятора.

3 - уровень сигнала.

4 - стрелка синхронизации.

5 - поплавок приемника.

6 - поплавок передатчика.

Если синхронизация ширины водопада с шириной полосы приемника отключена, то позиционирование и ширина водопада производится с помощью мыши:

- Левая кнопка и перемещение влево/вправо - позиционирование водопада.

- Правая кнопка и перемещение влево/вправо - ширина водопада.

Для быстрой настройки на станцию можно использовать клик по водопаду, или вращение колесика мышки.

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


TCP Server

DIGI Server ››

Для управления Модемом из программы лога, поставьте отметку "Use TCP Server"

Работа модема начнется только после подключения лога к TCP серверу.

Created with the Personal Edition of HelpNDoc: Free EPub producer


Протокол управления Модемом через TCP Server

DIGI Server ››

SET_CHANNEL | Назначение канала для DIGI | Аргументы
Тип | Чтение/запись | arg1 – Номер приемника (0 – RX1,1 – RX2) arg2 – Номер VFO (0 – VFO A, 1 – VFO B) arg3 – Заголовок
Команда и аргументы | SET_CHANNEL: arg1, arg2, arg3;
Пример | RX_CHAR: 0, 1, Radio 1;

RX_CHAR | Чтение принятого символа | Аргументы
Тип | Чтение | arg1 – принятый символ Character code (ASCII) arg2 – отношение сигнал/шум в дБ arg3 – смещение (Гц)
Команда и аргументы | RX_CHAR: arg1, arg2, arg3;
Пример | RX_CHAR: 48,17,1503;

TX_CHAR | Чтение переданного символа | Аргументы
Тип | Чтение | arg1 – Переданный символ Character code (ASCII)
Команда и аргументы | TX_CHAR: arg1;
Пример | TX_CHAR: 48;

TX_EMPTY | Сигнал перед передачей последнего символа в режиме терминала | Аргументы
Тип | Чтение |
Команда и аргументы | TX_EMPTY;
Пример | TX_EMPTY;

DIGI_MODE | Модуляция | Аргументы
Тип | Чтение/Запись | Arg1 – Модуляция : RTTY45; RTTY75; BPSK31; BPSK63; BPSK125;
Команда и аргументы | DIGI_MODE: arg1;
Пример | DIGI_MODE: RTTY45; RTTY75; BPSK31; BPSK63; BPSK125;

TX_STATUS | Начало/завершение передачи | Аргументы
Тип | Чтение | Arg1 – 0 прием, 1 передача
Команда и аргументы | TX_STATUS: arg1;
Пример | TX_STATUS: 1;

DX_TX | Корреспондент: начало/окончание передачи. | Аргументы
Тип | Чтение | Arg1 – 1 начал передачу, 0 - закончил
Команда и аргументы | DX_TX:arg1;
Пример | DX_TX: 1; DX_TX:0;

DIGI_MSG | Текст для передачи | Аргументы
Тип | Чтение | Arg1 – текст для передачи TX включается автоматически с выдачей TX_STATUS: 1;. После завершения передачи – переходит на прием с выдачей TX_STATUS: 0;
Команда и аргументы | DIGI_MSG: arg1;
Пример | DIGI_MSG: «CQ TEST»;

TX_STOP | Остановить передачу | Аргументы
Тип | Чтение |
Команда и аргументы | TX_STOP;
Пример | TX_STOP;

AFC | Включить AFC | Аргументы
Тип | Чтение, запись | Arg1 – 0 выключить, 1 включить.
Команда и аргументы | AFC: arg1;
Пример | AFC: 1;

NET | Установить смещение TX=RX | Аргументы
Тип | Чтение, запись | Arg1 – 0 выключить, 1 включить.
Команда и аргументы | NET: arg1;
Пример | NET: 1;

OFFSET | Установить смещение | Аргументы
Тип | Чтение, запись | Arg1 – смещение.
Команда и аргументы | OFFSET: arg1;
Пример | OFFSET: 1600;

RX_SN | Установить смещение | Аргументы
Тип | Чтение | Arg1 – уровень в дБ.
Команда и аргументы | RX_SN: arg1;
Пример | RX_SN: 15;

TERMINAL | Включить терминал | Аргументы
Тип | Запись | Arg1 – 0 – выключить, 1- включить.
Команда и аргументы | TERMINAL: arg1;
Пример | TERMINAL: 1;

SET_TXDELAY | Установить задержку передачи | Аргументы
Тип | Чтение, запись | Arg1 – задержка, мс.
Команда и аргументы | SET_TXDELAY: arg1;
Пример | SET_TXDELAY: 100;

Created with the Personal Edition of HelpNDoc: Free PDF documentation generator


Пример работы DIGI Server с 5MContest

DIGI Server ››

Работа 5MContest и SDC DIGI Server описана тут .

Видео работы

Created with the Personal Edition of HelpNDoc: Full-featured multi-format Help generator


Macros Server

Вкладка "Macro" предназначена создания окон панелей для передачи макросов через TCI соединение. Для каждого приемника можно создавать свою панель. Панель может не имет экранной формы и работать через свой TCP сервер. Через этот сервер можно передавать названия WAV - файлов для проигрывания их через TCI соединение. Например,

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Настройки панели

Macros Server ››

TCI Client - выбирается клиент TCI из вкладки "TCI".

Receiver - номер приемника.

External Window - будет создаваться внешняя панель функциональных кнопок.

Stays on Top - панель будет отображаться на переднем плане.

Min/Close button - отображать кнопки минимизации и закрытия окна.

Hook key F1-F12 - перехват кнопок F1-F12, ESC если фокус находится в другом приложении. Только для Windows!

+Ctrl - нажатия функциональных клавиш на клавиатуре должны производиться совместно с коавишей Ctrl.

+Shift - нажатия функциональных клавиш на клавиатуре должны производиться совместно с коавишей Shift.

Use in CW - использовать внешнее окно с видом модуляции CW.

Use in DIGI - использовать внешнее окно с видом модуляции DIGI. Вы должны указать, через какой модем (вкладка DIGI) будут передаваться макросы.

Use in SSB - использовать внешнее окно с видом модуляции SSB.

Audio Level - громкость проигрывания WAV файлов.

Use TCP Server - панель будет иметь свой TCP сервер, через который внешняя программа лога может управлять передачей аудио файлов.

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Внешняя панель

Macros Server ››

Внешнее окно с функциональными кнопками выводится на экран, если панель макросов активна и в её настройках указано "External Window".

CW - вид модуляции. Для перемещения окна по экрану нажмите левую кнопку мышки и двигайте её.

WPM - скорость передачи CW.

Esc - кнопка для отмены передачи.

Hook - производится перехват нажатий кнопок F1-F12 и ESC у других приложений.

Slim - включение режима Slim.

F1-F12 - кнопки макросов.

Send - передать введеный текст.

Clear - очистить протокол переданных текстов.

Created with the Personal Edition of HelpNDoc: Create iPhone web-based documentation


Режим Slim

Macros Server ›› Внешняя панель ››

Чтобы включить этот режим поставьте отметку "Slim"

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


Настройка макросов

Macros Server ››

Для вызова окна настроек макросов нажмите кнопку:

Окно ввода макросов:

После внесения изменений нажмите кнопку "Apply"

Ввод названий файлов для макросов SSB:

Created with the Personal Edition of HelpNDoc: Generate EPub eBooks with ease


Телнет сервер

Эта утилита используется для объединения спотов, поступающих из различных источников в один поток со своим сервером, который в свою очередь используется для подключения к нему программ логов. Рассмотрим на примере создания сервера для объединения спотов с двух скиммеров и RBN.

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Telnet Server

Телнет сервер ››

Это сервер, к которому непосредственно будут подключаться программы логов.

[Start] – кнопка запуска сервера. Кнопка должна постоянно находиться в нажатом состоянии.

Под кнопкой Start будут появляться иконки программ, которые подключились к серверу.

Port: - номер порта сервера.

Log – для просмотра протокола обмена лог-сервер.

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Spots -> Panorama

Телнет сервер ››

Раздел предназначен для управления процессом вывода спотов на панораму программы ExpertSDR2 в совокупности с работой конест-лога 5MContest, либо любого другого лога, который может управлять работой скиммера.

New, Mult, Dupe – указывают, какие позывные будут отображаться на панораме. Справа от них расположены кнопки, которыми можно установить цвет, которым будут отображаться эти позывные. Если повторы (Dupe) не отмечены, то такие позывные будут автоматически исчезать с панорамы после проведения связи с ними.

Программа SDC-Telnet Server сама определяет, тил лога, который к ней подключился. Если программа лога не сообщает статус позывного (Mult, New,..Dupe), то синяя стрека показывает, что цвет спотов на панораме трансивера будет выбран "Defaul and Bypass Mode Color".

Если подключился лог, который сообщает тип спота (5MContest, LogHX) то цвет позывного будет определяться так:

Правее расположен ряд кнопок для подачи сообщений в системном трее. Например, чтобы при появлении станции-множителя раздался звуковой сигнал и появилось сообщение в системном трее, отметте динамик напротив "Mult":

Верхняя кнопка включает/отключает все сообщения.

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


N1MM

Телнет сервер ›› Spots -> Panorama ››

SDC позволяет пересылать споты из программы N1MM.

Для этого необходимо указать адрес и порт сервера программы N1MM и поставить галку N1MM:

Attention!!!

With version 10.68, the checkbox "N1MM" can not be removed. If the SDC does not receive parcels from the N1MM within 30 seconds, it will automatically switch to the color bypass mode. When the parcels from the N1MM appear, the program automatically switches to the color processing mode.null

Настройка программы N1MM:

Created with the Personal Edition of HelpNDoc: Easily create Qt Help files


Add Windows

Телнет сервер ››

Connect and Start SKM Server - при запуске споттеров, или при подключении программы лога к порту Telnet Server будет автоматически подключены и включены скиммеры из вкладки SKM Server.

ActiSpot – окно, в котором отображаются споты Вашей станции (как правило используются споты кластера RBN).

Use BandMap for RX1 - открыть окно карты диапазона для 1-го приемника.

Use BandMap for RX2 - открыть окно карты диапазона для 2-го приемника.

Created with the Personal Edition of HelpNDoc: Create help files for the Qt Help Framework


Acti Spot

Телнет сервер ›› Add Windows ››

Окно Acti Spot предназначено для быстрого визуального контроля и управления некоторыми функциями.

1 - поле, где будут отображаться споты Вашей станции. Например:

2 - Callsign for search. По умолчанию производится поиск позывного, указанного в настройках споттеров. Но Вы можете дать задание искать другой позывной, если введете его в это поле.

3 - Состояние подключения споттеров к Telten Server. В данном случае они отображают три столба: сервер RBN и два скиммера. Второй скиммер в данном случае не активен.

4 - Тремометры, отображающие активность споттеров. Чем больше спотов по нима поступает, тем быстрее бегут указатели термометров.

5 - Термометры, отображающие количество работающих декодеров в соответствующем скиммере.

6 - Быстрый доступ к настрокам окна "Spots -> Panorama", позоляющий оперативно управлять потоком спото на панораму. В данно случае указано, что на панораме буду отображаться станции-множители, новые станции на диапазоне, просто новые станции, но повторы отображаться не будут.

7 - Динамик включает звуковое оповещение о появлении станции. "599" - включает функцию "599" для работы в Pile-Up, 5 - ширина Pile-Up в kHz.

8 - Поле, куда вводится аббревиатуры теста. Это поле дублирует поле "With Abbreviation Test Only" в окне SKM-Server.

9 - Кнопка перезапуска скиммеров. Таблица декодированных позывных будет очищена и споты будут выданы без ожидания окончания интервала выдачи спотов.

Элементы управления, добавленные в новых версиях:

1. Чекбокс быстрого включения/отключенияя скиммера (кластера)

2. Быстрая смена вида модуляции скиммера.

3. Быстрый доступ для включения функции "599".

1. Установка минимального порога громкости станции для выдачи спота скиммерами. Отношение сигнал/шум в dB. Значение по умолчанию = -10.

2. Включает автоматическое управление скоростью CW передачи при настройке трансивера на данную станцию. Работает только с трансиверами, работающими через протокол TCI.

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Band Map

Телнет сервер ›› Add Windows ››

BandMap for RX1, RX2 – бендмапы, отображающие состояние диапазона вблизи частоты настройки.

Если трансивер работает в режиме SO2V, то Band Map2 отображает данные по частоте VFOB. В режиме SO2R Band Map 2 отображает данные по второму приемнику.

Допускается клик по шкале Band Map, или по конкретному позывному.

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Установки менеджера споттеров

Телнет сервер ››

Default Profile: - профиль, который будет загружаться при подключении лога, которые не отвечает статусами позывных.

– удалить выбранный профиль.

- перезаписать выбранный профиль.

- ввести имя профиля и сохранить его.

Special profile For 5MContest – указывается профиль, который будет загружаться при подключении контест лога 5MContest.

[Start Spotters] – ручной запуск всех споттеров, которые отмечены галками. Кнопка «нажимается» автоматически при подключении лога к «Telnet Server».

[ +] – добавить окно споттера справа.

[ -] – удалить крайнее правое окно споттера.

Callsign – позывной, который будет использоваться при подключении к споттерам.

Created with the Personal Edition of HelpNDoc: Single source CHM, PDF, DOC and HTML Help creation


Установки споттера

Телнет сервер ››

to Srv - отправлять споты в Telnet Server для раздачи клиентам.

to Pan - отправлять споты на панораму траснивера, подключенного через порт TCI. Если отметить галку, то можно установить цвет для спотов на панораме:

Внимание, если подключен лог, которые сообщает статус позывного, то установка цвета игнорируется.

Log - показывать поток спотов в окне лога.

Created with the Personal Edition of HelpNDoc: Easily create EBooks


Создание сетевых аудио каналов

Создание сетевых каналов для передачи звука и телеграфного ключа ››

Программа SDC позволяет создать передачу звуковых потоков через сеть. Каждый канал позволяет передачу-прием в оба направления.

Рассмотрим на примере создание одного канала передачи звука.

На двух компьютерах устанавливается программа SDC. На оном компьютере во вкладке "RMT Server" срздаем "Audio Server 1", на втором во вкладке "Audio Client" создаем "Audio Channel 1":

На сервере будет подключен микрофон и передан на второй компьютер.

Add Block - это количество дополнительных блоков буфера. Их число зависит от качества сети. Чем больше задержки в сети, тем большее количество блоков необходимо зарезервировать. Оптимальное значение для драйвера MME: Buffer = 4096, add Block = 2.

Если Вы планируете передавать звуковые потоки в обе стороны, настройки будут выглядеть примерно таким образом:

Вы должны указать только аудио устройства в которые будет передаваться/приниматься аудиопоток. Остальные параметры (Mono/Stereo, Sample< Size, Buffer) будут устанавливаться клиентом (программа SDC):

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


Подключение телеграфного ключа

Создание сетевых каналов для передачи звука и телеграфного ключа ››

Программа SDC позволяет передать на удаленный компьютер телеграфную манипуляцию. При этом будет создаваться промежуточный буфер работы ключа, который потом будет воспроизводиться на удаленном компьютере.

Раздел «CW Key» прикреплен к аудио каналу т.к. подразумевается их совместное использование. Например:

Телеграфный ключ подключен к потру COM4. Манипуляция передается в COM Spider к порту "to Remote 847", который через сеть подключен к LAN-COM Interface 1 на первом компьютере.

Настройки телеграфного ключа:

Speed – скорость работы ключа.

Volume – громкость прослушивания CW манипуляции.

BreakIn - устанавливает режим BreakIn и время задержки перехода на прием после последнего знака.

Delay PTT-CW – время, на которое будет задержана передача CW сигнала после включения PTT. На это время будут сдвигаться все телеграфные посылки. Не будет происходить укорочение первой посылки.

CW Pitch – высота тона прослушивания CW.

Ramp – скорость нарастания фронтов CW.

Width – коррекция отношения длины точка/тире.

Type Key – указывается полярность CW ключа, или его тип.

COM Port Key – указывается физический COM порт для подключения CW ключа.

Схема подключения ключа:

To Spider – порт раздела COM Spider, в который будет передаваться CW+PTT манипуляция.

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Создание удаленного канала с самоконтролем CW для ключа и лога

Создание сетевых каналов для передачи звука и телеграфного ключа ››

Одновременно Вы можете подключить CW+PTT манипуляцию из программа контест-лога:

При такой настройке Вы можете передавать на удаленный компьютер манипуляцию из контест-лога и телеграфного ключа. При этом самоконтроль будет выводиться на звуковое устройство, указанное в "Audio Client"->Output.

.

Created with the Personal Edition of HelpNDoc: Easily create Web Help sites


Audio Mixer

Эта утилита используется для решения задач с аудио каналами. Например, условиями соревнований оговорено, что, если используется режим SO2R, то аудио запись связей должна производиться в один файл в стерео режиме, RX1 – левый канал, RX2 – правый.

В разделе «Input Device» добавляем два аудио устройства, к которым подключены трансиверы. В разделе «Output Device» вводим устройство, на которое будет производиться запись. В разделе «Sliders» вводим т.н. слайдеры, которыми устанавливается соединения и уровни громкости:

Если трансивер (или его программа) имеют разные аудио каналы для воспроизведения приема и самоконтроля, то для записи необходимо их объединить и передать в соответствующие каналы на выходе:

В разделе Слайдеров есть установка "AGC". Она автоматически снизит уровни поступающих сингалов, если их суммарный уровень превысит максимум.

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Audio Scope

Audio Scope предназначен за наблюдением спектра и осциллограммами низкочастотных сигналов.

- кнопки добавления, или удаления последнего Audio Scope.

- синхронизировать запуск Аудиоскопа с запуском трансивера, подключенного по протоколу TCI. Клиент TCI выбирается из списка.

- тип окна. SpectroScope - отображать только спектр, OscilloScope - отображать только осциллограмму, Both Vertical, Horisontal - оба окна.

In External Window - окно графики выводить в отдельное окно на экране монитора.

- выбирается тип драйвера, устройство. Для построения спектра указывается Channel, Sample Rate и FFT Size.

- дополнительные настройки для спекра: усреднение и отображение максимальных пиковых уровней.

- дополнительные настройки для OscilloScope. Выбирает режим сдвига старой развертки и периодичность обновления осциллограммы.

Если отображаются оба графическихз окна, то их соотношение можно менять разделителем:

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Set Gain & Scale

Audio Scope ››

SpectroScope.

Для настройки шкалы децибел и ширины частотного участка нажмите правую кнопку мышки и перемещайте её влево-вправо,вверх-вниз.

Для позионирования участка спектра нажмите левую кнопку мышки и перемещайте её влево-вправо,вверх-вниз.

Вращение колесика мышки дополнительно регулирует шкалу децибел.

OscilloScope.

Для изменения чувствительности вращайте колесико мышки, либо нажмите правую кнопку и перемещайте мышку вверх/вниз.

Для изменения скорости нажмите правую кнопки мышки и перемещайте её горизонтально.

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


PA

Вкладка PA предназначена для управления усилителями мощности.

Частота настройки активного VFO отслеживается программой SDC PA и передается в усилитель через COM порт.

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Тип устройства

PA ››

Версия SDC 10.23 позволяет управлять усилителями, поддерживающими протоколы CAT фирм KENWOOD, ICOM, Elecraft, RF-Kit PA

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Источник данных

PA ››

Для определения частоты активного могут использоваться данны из вкладки RigSync, или из вкладки TCI.

При выборе в качестве источника данных Rig Sync, необходимо указать этот канал:

Если выбран TCI, то указывается клиент TCI и приемник, к которому будет подключен данный усилитель:

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


PTT

PA ››

Если в качестве источника данных выбран клиент TCI, то Вы можете реализовать управление PTT для усилителя, используя сигнал RTS, или DTR этого COM порта:

Дополнительно Вы можете установить задержку включения PTT сигнала после передачи в усилитель новой частоты настройки VFO - роле "Latency". Эта задержка не будет использоваться, если в момент сигнала PTT не будет происходить изменение частоты VFO.

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Elecraft

PA ››

Если Вы используете усилитель фирмы Elecraft, то будут доступны следующие пункты:

Attenuator - при подключении к усилителю будет автоматически включаться внутренний аттенюатор.

Antenna, Band, Erase - выбирается антенна, диапазон, нажимается кнопка "Erase" для очистки настроек тюнера.

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


KENWOOD, Icom

PA ››

Если Вы используете усилитель, поддерживающий CAT фирм KEWOOD, или Icom? то будут доступны следующие пункты:

Time Poll - время, через которое будет производиться передача частоты VFO в усилитель.

Type Poll:

Only Cyclic Control - будет периодически передаваться частота VFO.

Send Changes & Cyclic Control - изменения частоты VFO будут высылаться мгновенно и повторяться через время Time Poll.

Send Changes & Polling - изменения частоты VFO будут высылаться мгновенно и будет производиться опрос готовности устройства через время Time Poll.

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Соединительные кабели

PA ››

Created with the Personal Edition of HelpNDoc: Easily create HTML Help documents


1K-FA

PA ›› Соединительные кабели ››

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


KXPA100

PA ›› Соединительные кабели ››

Created with the Personal Edition of HelpNDoc: Easily create EBooks


OTRSP

SDC-OTRSP - это программа-посредник между логом и трансвиером, который работает под управлением ExpertSDR2. Она принимает команды через COM порт и управляет уровнями громкостей каналов звука и их балансом. На основании этих команд работает управление панелью управления E-Coder.

Протокол описан тут.

В зависимости от принятой через COM порт команды и вида работы трансивера (SO2V/SO2R) активируется соответствующая настройка громкости и баланса. Например, при получении команды RX2S в трансивер будут переданы настройки из раздела RX2 Stereo.

COM Port - COM порт для приема команд от лога.

TCI Fro RX1 - TCI клиент для 1-го трансивера.

TCI Fro RX2 - TCI клиент для 2-го трансивера. Если используется один трансивер, то имя клиента должно быть одинаковым.

Auto control E-Coder - управлять VFO и RX1/RX2 панели E-Coder.

Created with the Personal Edition of HelpNDoc: Produce online help for Qt applications


Поддерживаемые команды

OTRSP ››

RX1 - активен 1-й приемник в режиме Моно.

RX1S - активен 1-й приемник в режиме Стерео.

RX2 - активен 2-й приемник в режиме Моно.

RX2S - активен 2-й приемник в режиме Стерео.

VFOA, VFO1 - активено VFOA 1-го приемника в режиме Моно.

VFOAS VFO1S - активено VFOA 1-го приемника в режиме Стерео.

VFOB, VFO2 - активено VFOB 1-го приемника в режиме Моно.

VFOBS, VFO2S - активено VFOB 1-го приемника в режиме Стерео.

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


SWR Meter

Вкладка SWR прредназначена для построения графика SWR антенны. Используется режим Tune трансиверов под управлением программы ESDR2 не ниже версии 1.3.0 beta 3. Для нормальной работы измерителя SWR следите за тем, чтобы регулятор Tune обеспечивал не менее 3 Вт на выходе передатчика.

Выберите диапазон (Band), шаг (Step), границы частот (Start-Stop) и нажмите "Start":

После сканирования диапазона Вы можете сохранить результаты этого измерения в файл. Для этого в разделен History уточните название файла и нажмите кнопку "Save". По умолчанию предлагается имя файла состоящее из даты и времени.

Вы можете совмещать до 4-х измерений в одной диаграмме.

Created with the Personal Edition of HelpNDoc: Create help files for the Qt Help Framework


Пример использования программы совместно с 5MContest

Программу «SDC» можно использовать, как альтернативу подпрограмме 5MTelnetServer, которая входит в состав 5MContest. Процесс запуска «SDC» включен в запуск 5MContest.

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Установки в 5MContest

Пример использования программы совместно с 5MContest ››

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


CAT интерфейс

Пример использования программы совместно с 5MContest ›› Установки в 5MContest ››

1. Настраиваем подключение к ExpertSDR2 во вкладке TCI1.

2. Вкладка "Radio settings":

Created with the Personal Edition of HelpNDoc: Create HTML Help, DOC, PDF and print manuals from 1 single source


Подключение к SDC Telnet Server

Пример использования программы совместно с 5MContest ›› Установки в 5MContest ››

Created with the Personal Edition of HelpNDoc: Free EPub producer


Запись QSO

Пример использования программы совместно с 5MContest ›› Установки в 5MContest ››

Если Вы используете трансивер SunSDR2 (PRO,DX,MB1) ExpertSDR3, то запись QSO может производиться без использования звуковых устройств:

Created with the Personal Edition of HelpNDoc: Create help files for the Qt Help Framework


SDC

Пример использования программы совместно с 5MContest ››

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Setup

Пример использования программы совместно с 5MContest ›› SDC ››

В окне Setup ставим галки:

«Move to SysTray on AutoStart» - при запуске на показывать окно программы, сразу перемещать его иконку в трей.

«Set no-kill window» - устанавливается «неубиваемость» программы при нажатии крестика в правом верхнем углу.

Created with the Personal Edition of HelpNDoc: Free EBook and documentation generator


Telnet Server

Пример использования программы совместно с 5MContest ›› SDC ››

Например, мы планируем использовать два скиммера и сервер RBN для отслеживания спотов своего позывного.

После ввода всех установок, вносим имя (например, 4k+TCI+RBN) в поле ввода и нажимаем кнопку создания нового профиля.

После этого выбираем этот профиль из списка и ставим галку «Use a special profile when 5MContest connected». Теперь, при подключении программы 5MContest к Telnet Server будет автоматически выбираться установки из сохраненного ранее профиля.

Внимание! При подключении программы 5MContest в разделе «Telnet Server» появится ярлычок этой программы:

Created with the Personal Edition of HelpNDoc: Produce online help for Qt applications


SKM Server

Пример использования программы совместно с 5MContest ›› SDC ››

Во вкладке SKM Server вводим два скиммера с примерно такими установками:

Сохраняем установки в соответствующий профиль.

Created with the Personal Edition of HelpNDoc: Full-featured EBook editor


TCI

Пример использования программы совместно с 5MContest ›› SDC ››

Если Вы хотите, чтобы курсор автоматически возвращался в окна программы 5MContest, то настройте TCI-Focus Helper:

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Установки программы ExpertSDR2

Пример использования программы совместно с 5MContest ››

В настройках программы ExpertSDR2 необходимо согласовать только номер порта интерфейса TCI и поставить галку “Enable”:

Для работы системы TCI-CallBack вводим источник спотов в раздел "Spot Setting":

Created with the Personal Edition of HelpNDoc: Easy CHM and documentation editor


DIGI

Пример использования программы совместно с 5MContest ››

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


5MContest

Пример использования программы совместно с 5MContest ›› DIGI ››

Открываем два окна для работы цифровыми видами связи.

Размещаем окна на экране. Например:

В окне Radio (1)/(2) - SDC DIGI Server вызвать меню Settings->Global Setup. Там необходимо указать номера портов модемов SDC-DIGI Server. Так же выбираются номера приемника и VFO. Например:

Created with the Personal Edition of HelpNDoc: News and information about help authoring tools and software


SDC

Пример использования программы совместно с 5MContest ›› DIGI ››

В SDC-DIGI Server открываем два Модема и настраиваем их.

Нажать кнопку "Start" в SDC-DIGI Server. Появятся два окна с водопадами, разместите их на экране. Например:

Создайте профиль в SDC-DIGI Server, сохраните установки.

Окна водопадов будут автоматически появляться на экране, если на трансивере установлен вид модуляции DIGI и к TCP серверам модемов подключилась программа лога.

Если окна не появлись, откройте SDC-DIGI Server, Вы увидите причину:

Видео работы

Created with the Personal Edition of HelpNDoc: Generate Kindle eBooks with ease


SBB

Пример использования программы совместно с 5MContest ››

Для работы в SSB в SDC предусмотрена передача звуковых файлов через TCI. Для этого не нужны никакие аудиосоединения. SDC-Macro получает название файла и проебразовывает его в IQ поток и передает его в трансивер через интерфейс TCI. Для работы в режиме двух приемников в SDC-Macro создаем две панели Macro с такими учстановками:

Не забудьте отметить, что SDC-Marco будет использоваться в модуляции SSB.

В программе 5MContest:

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Пример использования программы совместно с LogHX

Программа LogHX так же, как и программа 5MContest, может обрабатывать полученные споты и отвечать строками с указанием статуса позывных. Сама процедура передачи спота выглядит так:

Скиммеры программы SDC будут ловить позывные и отправлять их на проверку в LogHX.

LogHX будет отвечать телнет-серверу SDC с указанием, что это за позывной (новый, новая страна, повтор)

SDC Telnet Server будет сам передавать позывные на панораму трансивера.

Таким образом отображаться на панораме будут только те позывные, которые декодированы скиммерами, но прошедшие проверку в LogHX.

Created with the Personal Edition of HelpNDoc: Easily create Qt Help files


Установки в программе LogHX

Пример использования программы совместно с LogHX ››

В окне Cluster - Localhost настроки такие:

Указывается адрес и порт SDC-Telnet Server

Если Вы хотите, чтобы на панораме трансивера отображались только споты от скиммеров SDC, то в настройке LogHX - TCI отключите передачу позывных на панораму непосредственно из лога:

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Установки в программе SDC

Пример использования программы совместно с LogHX ››

В SDC - TelnetServer отмечаются типы позывных, которые отправляются на панораму трансивера и указывается их цвет:

Проверьте подключение программы LogHX к SDC-Telnet Server. В разделе "Telnet Server" должен появится логотип программы LogHX.

При подключении LogHX к SDC-Telnet Server будет выбран профиль, указанный в "Profile".

Created with the Personal Edition of HelpNDoc: Produce online help for Qt applications


Пример использования программы с N1MM

Программа SDC работает посредником между программой SDR и N1MM.

Схема рабоы:

Created with the Personal Edition of HelpNDoc: Create help files for the Qt Help Framework


CAT+PTT+CW

Пример использования программы с N1MM ››

Управление CAT, PTT, CW будем рассматривать для двух типов работы: SO2V и SO2R.

Created with the Personal Edition of HelpNDoc: Free Qt Help documentation generator


Виртуальные COM порты

Пример использования программы с N1MM ›› CAT+PTT+CW ››

Для соединения CAT систем программ необходимо создать минимум четыре пары виртуальных COM портов. Для этого рекомендуется использование программы com0com: https://code.google.com/archive/p/powersdr-iq/downloads

Создайте пары: COM3-COM4, COM5-COM6, COM7-COM8, COM9-COM10.

Created with the Personal Edition of HelpNDoc: iPhone web sites made easy


Установки в N1MM

Пример использования программы с N1MM ›› CAT+PTT+CW ››

В окне "Configurer" устанавливаем вид работы "SO2R" и указываем следующие COM порты:

Нажимаем кнопки "Set" и настраиваем порты.

COM6, CAT система для 1-го Радио:

COM4, управление PTT и CW для 1-го Радио:

COM8, CAT система для 2-го Радио:

COM10:

Created with the Personal Edition of HelpNDoc: Free HTML Help documentation generator


Установки в ExpertSDR2

Пример использования программы с N1MM ›› CAT+PTT+CW ››

CAT для 1-го Радио:

CAT для 2-го Радио:

Управление PTT+CW:

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


Соединение SDC и ExpertSDR2

Пример использования программы с N1MM ››

Процедура подключения SDC к ExpertSDR2 подробно описана в разделе TCI .

Created with the Personal Edition of HelpNDoc: Full-featured Kindle eBooks generator


Подключение N1MM к SDC-Telnet Server

Пример использования программы с N1MM ››

В программе SDC-Telnet Server имеется аггрегатор, который позволит собрать споты из нескольких источников и передать их в рпограмму N1MM

Created with the Personal Edition of HelpNDoc: Easy to use tool to create HTML Help files and Help web sites


Установки в программе SDC

Пример использования программы с N1MM ›› Подключение N1MM к SDC-Telnet Server ››

In the SDC-Telnet Server, enter the server port number 7373 and press "Start".

Created with the Personal Edition of HelpNDoc: Easily create Help documents


Установки в N1MM

Пример использования программы с N1MM ›› Подключение N1MM к SDC-Telnet Server ››

В меню N1MM "Window" нажмите "Telnet". Появится окно настроек "Telnet". Во вкладке "Cluster" нажмите кнопку "Edit List". В свободной строке введите название "SDC", а в колонке "URL" - 127.0.0.1:7373, и нажмите "Ок".

В выпадающем меню выберите "SDC" и нажмите "Connect to SDC":

Во вкладке "SDC" появится протокол подключения, а в окне "SDC-Telnet Server" появится цифра [1] - это количество подключенных программ.

Created with the Personal Edition of HelpNDoc: Free help authoring tool


Добавление внешних кластеров в SDC-Telnet Server

Пример использования программы с N1MM ›› Подключение N1MM к SDC-Telnet Server ››

Если необходимо, добавьте внешние кластеры в аггрегатор:

Created with the Personal Edition of HelpNDoc: Write EPub books for the iPad


Подключение к SDC SKM Server

Пример использования программы с N1MM ›› Подключение N1MM к SDC-Telnet Server ››

В окне настройки SDC Telnet Server поставьте отметку "Connect and Start SKM Server". При подключении N1MM к SDC, Telnet Server будет автоматически подключаться к скиммерам SKM-Server и стартовать их.:

Created with the Personal Edition of HelpNDoc: Free Web Help generator


Настройка SDC SKM-Server

Пример использования программы с N1MM ››

Во вкладке SDC-SKM Server откройте (кнопка "+") два скиммера и настройте их. Сохраните настройки в профиль "N1MM".

Включите трансивер в режиме одного приемника и нажмите кнопку SDC-SKM Server -> [Start SKM Server]. Убедитесь, что скиммер 1 работает, Настройтесь на станцию, в одке декодера "A:" должен появиться текст CW передачи.

Возьмите декодер за букву A, или B и разместите его в удобном для Вас месте.

Подробно настройке окна декодера.

Подробно о настройках SKM Server.

Не забывайте, что после изменений настроек необходимо сохранять их в профиле.

Created with the Personal Edition of HelpNDoc: Easily create CHM Help documents


Передача спотов на панораму ExpertSDR2

Пример использования программы с N1MM ››

Сначала проследите, чтобы в настройках ExpertSDR2 стояла отметка "Show Spots"

Created with the Personal Edition of HelpNDoc: Produce electronic books easily


Установки в N1MM

Пример использования программы с N1MM ›› Передача спотов на панораму ExpertSDR2 ››

Откройте окно настройки N1MM, вкладку "Broadcast Data", поставьте отметку "Spots":

Created with the Personal Edition of HelpNDoc: Benefits of a Help Authoring Tool


Установки в программе SDC

Пример использования программы с N1MM ›› Передача спотов на панораму ExpertSDR2 ››

Работает два способа передачи спотов на панораму ExpertSDR2.

1 - Режим без обработки в N1MM (bypass). При таком способе, споты от скиммеров, внешних кластеров (с отметкой "to Pan") будут собираться в системе "Spots -> Panorama" и отправляться на панораму трансивера. При этом расцветка спотов будет соответствовать указанному цвету в настройке споттера (кластера).

2 - Режим с обработкой в N1MM. Для этого необходимо адрес и номер порта в N1MM и поставить отметку "N1MM". Если параметры указаны верно и нет ограничений на передачу данных от N1MM в настройках компьютера, то включится этот режим. При этом появится 4 синих треугольника около отметок "Mult...Dupe" - это является основным признаком того, что ражим работает. Если в течении 30 секунд не будут поступать данные от N1MM, то автоматически включится режим "bypass".

Во втором режиме цвета спотов на панораме будут зависеть от настроек в SDC, которые Вы можете изменить. Так же, устанавливая отметки "Mult"..."Dupe", Вы указываете, какие типы спотов будут отображаться на панораме. В данном случае, будут отображаться все виды спотов.

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Focus Helper

Пример использования программы с N1MM ››

Система "Focus Helper" предназначена для автоматического возврата фокуса ввода в окно N1MM в случае его потери. См. подробное описание в TCI .

Created with the Personal Edition of HelpNDoc: Easily create EPub books


Пример использования SKM Server без программы лога

SDC можно использовать просто для декодирования CW станций и отображения позывных на панораме трансивера.

Установки в программе SDC:

Установки в программе ExpertSDR2:

Created with the Personal Edition of HelpNDoc: Easy EBook and documentation generator


Пример создания удаленного рабочего места

Тут будет рассмотрен пример работы на удаленном трансивере SunSDR2.

Отображение окна программы ExpertSDR2 на домашний компьютер должно передаваться с помощью программ типа TeamViewer. Наша задача заключается в том, чтобы организовать передачу звуковых каналов, СОМ-портов, телеграфного ключа.

Created with the Personal Edition of HelpNDoc: What is a Help Authoring tool?


Звуковые каналы

Пример создания удаленного рабочего места ››

«Туда» передается микрофон, «Сюда» на динамик передается «SC» с удаленной программы ExpertSDR2.

Created with the Personal Edition of HelpNDoc: Free CHM Help documentation generator


СОМ порт «дома»

Пример создания удаленного рабочего места ››

В качестве удаленного порта использован «Remote Audio» и его канал «Audio 1».

Created with the Personal Edition of HelpNDoc: Easily create PDF Help documents


СОМ порт «там»

Пример создания удаленного рабочего места ››

Т.е., мы видим, что для передачи аудио каналов и СОМ порта будет использовано одно сетевое соединение. Работа педали будет передаваться на отдельный СОМ порт (СОМ11).

Аналогично можно настроить программу для удаленной работы на любом трансивере.

Created with the Personal Edition of HelpNDoc: Free Kindle producer


Автозагрузка программы SDC (Windows)

Нажмите кнопки Windows+R, появится окно "Выполнить". Введите shell:startup Введите и нажмите Ok:

Откроется папка "Автозагрузка", скопируйте в неё ярлык программы SDC.

Created with the Personal Edition of HelpNDoc: Benefits of a Help Authoring Tool


Установки программы

Style – стиль отображения.

Set no-kill window – программа не будет закрываться при нажатии на крестик закрытия окна. Окно программы будет сворачиваться в иконку в трее.

Move to SysTray on AutoStart or Minimized – при запуске не открывать окно программы, не показывать иконку в панели задач. Для вызова окна программы и её закрытия будет присутствовать иконка в трее.

Остальные установки касаются показа интерфейса соответствующих подсистем программы SDC и автоматического их запуска.

Created with the Personal Edition of HelpNDoc: Free EPub and documentation generator


Стили интерфейса

Установки программы ››

Выбор стиля "Fusion":

Выбор стиля "Ночь":

Created with the Personal Edition of HelpNDoc: Free iPhone documentation generator


Регистрация программы

Регистрация программы не является обязательным условием её использования.

После регистрации у Вас появятся такие возможности:

- Вы сможете использовать SKM Server совместно с SDR радио, которые не поддерживают TCI интерфейс.

- Вы можете автоматически получать новые обновления программы в ручном и автоматическом режиме.

Поддержите проект на сайте SDC любой доступной для Вас суммой, в сопроводительной записке платежа обязательно укажите свой позывной и электронный адрес, на который Вы получите ключ регистрации!

Created with the Personal Edition of HelpNDoc: Full-featured Help generator


Обновления программы

Новые версии программы доступны на сайте SDC в разделе "Загрузки".

Если Ваша программа зарегистрирована, Вы можете получать и устанавлвать обновления программы не посещая сайт.

Обновления будут закачиваться в папку пользователя LwSoft/Download и перед установкой Вы получите запрос на проведение этой процедуры.

Пример ручного запроса обновления. Обнаружена версия Beta 12.2118:

Created with the Personal Edition of HelpNDoc: Free help authoring tool